www.fltk.net > 我的jAvAwEB项目中用到了mAvEn,spring3,struts2...

我的jAvAwEB项目中用到了mAvEn,spring3,struts2...

这个是我的pom.xml里的信息:标签里写的是你的工程依赖其他的哪些工程 4.0.0 artcommon cn.com.btmu.art.service 1.0 btmu.art.dependencies core-base 1.0 artcommon cn.com.btmu.art.base 1.0 artcommon cn.com.btmu.art.foundation 1.0 artco...

如果是在eclipse中,可以看到运行时环境Maven Dependencies中有对应struts2的包

你这个是少了一个JAR包....com.springsource.org.aopalliance-1.0.0.jar 下载地址: http://sourceforge.net/projects/aopalliance/files/aopalliance/ 这个问题很常见...是因为你下的spring包里面没有这个....你单独下一个吧

你打包后就会出现在lib里的埃maven build一下啊,或者install一下。打好的包里就有把依赖包都加进入的了。

为什么不会,maven不就是为了方便jar包管理而设计的吗?不加载的话那不如创建动态网页项目了,不喜欢自动加载jar包手动复制jar包就可以了。

maven下载出现问题一般有几种情况:一是网络中的maven中央仓库里没有你定义的jar依赖,更谈不上下载;二是中央仓库有,但是下载时出错,并没有将所有文件下载到你的本地仓库中,依然不起作用,这种情况可以去本地仓库查看,一般是缺少jar文件,...

可以去技术帮网站看看,希望对你有帮助。

网站地图

All rights reserved Powered by www.fltk.net

copyright ©right 2010-2021。
www.fltk.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com